I got errors trying to install the .NET Core SDK on Pop!_OS.  Since this distro is based on Ubuntu, I followed the Ubuntu install steps but ran into an error running the install command.

sudo apt-get install dotnet-sdk-2.2

The following packages have unmet dependencies:
 dotnet-sdk-2.2 : Depends: aspnetcore-runtime-2.2 (>= 2.2.0) but it is not going to be installed
                  Depends: dotnet-runtime-2.2 (>= 2.2.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I tried using all the extra steps listing in the install page to the same result.  After a few searches on the InterWeb, I found a solution using Snap:

sudo apt install snapd
sudo snap install dotnet-sdk --classic
sudo snap alias dotnet-sdk.dotnet dotnet